Modify

Opened 14 months ago

Closed 3 months ago

Last modified 6 weeks ago

#12731 closed enhancement (fixed)

Add an option to completely prevent upload of a layer : e.g. "never" to upload=true/false

Reported by: jaakkoh Owned by: team
Priority: normal Milestone: 17.03
Component: Core Version:
Keywords: upload policy Cc:

Description (last modified by jaakkoh)

The most typical need for this extension might be training totally new people to the world of OSM, specifically using JOSM. There is commonly e.g. an example.osm file used to illustrate elements in OSM and how they show up & are manipulated in JOSM. The issue has been discussed at https://github.com/hotosm/learnosm/issues/335 . And the (currently last) comment from June 1, 2015.

Currently the most that can be done is to

  • use the upload=false and
  • then tell those that are trained not to upload their edited data -- and definitely not to "bypass" the prompt that warns not to upload the data (if someone does try to upload. And finally to
  • check the area where the example data is placed to see if anyone has ended uploading regardless of the above.

Experienced users and especially those that are more computer savvy than some might think that having upload=false is sufficient. But it's not. And the answer is not to put more emphasis to stressing the need to not upload when the upload tells not to.

So, simply said, there really should be an upload=never option, or something alike.

Attachments (1)

12731-upload-block.patch (10.3 KB) - added by bastiK 3 months ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 14 months ago by jaakkoh

Description: modified (diff)

(comment moved to the ticket itself)

Last edited 14 months ago by jaakkoh (previous) (diff)

comment:2 Changed 3 months ago by althio

That would be an interesting feature for our use case at LearnOSM https://github.com/hotosm/learnosm/issues/335

comment:3 Changed 3 months ago by stoecker

Why not simply use a wrong username/password?

Changed 3 months ago by bastiK

Attachment: 12731-upload-block.patch added

comment:4 Changed 3 months ago by bastiK

Attached patch implements the upload='never' flag. There is deliberately no GUI to toggle the flag, you need to edit the file in an editor to set or unset.

comment:5 in reply to:  4 Changed 3 months ago by Don-vip

Keywords: upload policy added; uploading removed
Milestone: 17.03

Replying to bastiK:

Attached patch implements the upload='never' flag.

xml_flag should be final (immutable enum)

Otherwise it's great !

comment:6 Changed 3 months ago by bastiK

Resolution: fixed
Status: newclosed

In 11709/josm:

fixed #12731 - Add an option to completely prevent upload of a layer : e.g. "never" to upload=true/false

to set this option, add XML attribute upload='never' to .osm file

comment:7 Changed 3 months ago by bastiK

In 11710/josm:

see #12731 - make enum field final + fix compiler warning

comment:8 Changed 3 months ago by Don-vip

In 11712/josm:

see #12731 - checkstyle/sonar

comment:9 Changed 3 months ago by althio

Thank you very much bastiK and Don-vip.
This works as intended on our side, we are very grateful for the implementation.

comment:10 Changed 6 weeks ago by openstreetmap.org-user-d1g

Thanks for implementing that!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.