Modify

Opened 21 months ago

Closed 7 days ago

Last modified 7 days ago

#12623 closed enhancement (fixed)

allow copying any text from note comments

Reported by: richlv Owned by: team
Priority: normal Milestone: 17.11
Component: Core notes Version: tested
Keywords: Cc:

Description (last modified by stoecker)

#12268 added basic note text copying, which is great :)

it would be even better if we could select the text in the popup, shown in the map view when we click a note.
clicking a specific comment there would allow selecting any text from it, ctrl+c would copy it.

a usecase i have right now - some 5th or so comment to a note has school names i would like to copy. that's still not possible in josm, i have to open the web map a this position & copy the names from there.

Attachments (2)

josm_notes.png (9.8 KB) - added by Don-vip 7 days ago.
josm_note_selection.png (7.8 KB) - added by richlv 7 days ago.
invisible selection

Download all attachments as: .zip

Change History (16)

comment:1 Changed 15 months ago by Don-vip

Ticket #13367 has been marked as a duplicate of this ticket.

comment:2 Changed 15 months ago by stoecker

Description: modified (diff)

comment:3 Changed 12 months ago by anonymous

Still not working on version 11283

comment:4 Changed 12 months ago by anonymous

wrong call on "Still not working on version 11283" sorry

comment:5 Changed 7 days ago by Don-vip

Milestone: 17.11

comment:6 Changed 7 days ago by Don-vip

Resolution: fixed
Status: newclosed

In 13111/josm:

fix #11217, fix #12623 - major rework of notes tooltips:

  • display clickable links
  • allow to copy text from notes, including comments

Changed 7 days ago by Don-vip

Attachment: josm_notes.png added

comment:7 Changed 7 days ago by Don-vip

Here's the result:


comment:8 Changed 7 days ago by richlv

testing with 13115, i still get the old style popups - cannot select any text. how so ?

comment:9 Changed 7 days ago by Don-vip

status report, note id and screenshot please :)

Changed 7 days ago by richlv

Attachment: josm_note_selection.png added

invisible selection

comment:10 Changed 7 days ago by richlv

oh damn. turns out i can select the text, but on my platform (linux, java 1.8.0_121) the highlight colour is invisible. see josm_note_selection.png, word "clock" is selected there.

can this be handled in this ticket, or should a new one be filed ?

Version 1, edited 7 days ago by richlv (previous) (next) (diff)

comment:11 Changed 7 days ago by Don-vip

What look and feel are you using?

comment:12 Changed 7 days ago by richlv

josm settings say "Metal"

comment:13 Changed 7 days ago by Don-vip

Metal defines the same color for tooltip background and text selection color... I don't plan to change this, it's a very minor problem, you can see the selected text changes from black to grey, and it works. You can also use a better look and feel (Gtk for example).

comment:14 Changed 7 days ago by richlv

thanks. is it work reporting this a separate problem for the metal theme ?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.