Modify

Opened 17 months ago

Closed 4 months ago

#12619 closed defect (duplicate)

IllegalArgumentException when loading SelectAction cursor

Reported by: gcpp.kalxas@… Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: cursor image width height linux x11 Cc: Komzpa

Description

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-13 01:17:21 +0100 (Sun, 13 Mar 2016)
Build-Date:2016-03-13 02:35:00
Revision:9979
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9979 en) Linux Ubuntu 14.04.4 LTS
Memory Usage: 155 MB / 957 MB (39 MB allocated, but free)
Java version: 1.7.0_95-b00, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u95-2.6.4-0ubuntu0.14.04.1


Last errors/warnings:
- E: java.lang.reflect.InvocationTargetException. Cause: java.lang.IllegalArgumentException: Width (0) and height (0) must be non-zero

java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1288)
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1263)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:98)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.IllegalArgumentException: Width (0) and height (0) must be non-zero
	at java.awt.image.ReplicateScaleFilter.<init>(ReplicateScaleFilter.java:102)
	at java.awt.Image.getScaledInstance(Image.java:173)
	at sun.awt.CustomCursor.<init>(CustomCursor.java:69)
	at sun.awt.X11CustomCursor.<init>(X11CustomCursor.java:43)
	at sun.awt.X11.XCustomCursor.<init>(XCustomCursor.java:42)
	at sun.awt.X11.XToolkit.createCustomCursor(XToolkit.java:1069)
	at org.openstreetmap.josm.tools.ImageProvider.getCursor(ImageProvider.java:1181)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.<init>(SelectAction.java:183)
	at org.openstreetmap.josm.gui.MapFrame.<init>(MapFrame.java:224)
	at org.openstreetmap.josm.Main.createMapFrame(Main.java:779)
	at org.openstreetmap.josm.Main.addLayer(Main.java:767)
	at org.openstreetmap.josm.Main.addLayer(Main.java:752)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$AbstractInternalTask.addNewLayerIfRequired(DownloadOsmTask.java:276)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$AbstractInternalTask.loadData(DownloadOsmTask.java:283)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:367)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:101)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:302)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:745)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:706)
	at java.awt.EventQueue$3.run(EventQueue.java:704)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:77)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:715)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1655)
	at java.awt.Component.setVisible(Component.java:1607)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$4.run(PleaseWaitProgressMonitor.java:197)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:745)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:706)
	at java.awt.EventQueue$3.run(EventQueue.java:704)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:77)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:715)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (10)

comment:1 Changed 17 months ago by gcpp.kalxas@…

Resolution: invalid
Status: newclosed

This problem appeared only on a KVM environment.
After testing under VirtualBox on another machine, it works fine...

comment:2 Changed 11 months ago by Don-vip

Resolution: invalid
Status: closedreopened

comment:3 Changed 11 months ago by Don-vip

Priority: criticalnormal

comment:4 Changed 11 months ago by Don-vip

Ticket #13469 has been marked as a duplicate of this ticket.

comment:5 Changed 11 months ago by Don-vip

Ticket #13496 has been marked as a duplicate of this ticket.

comment:6 Changed 11 months ago by Don-vip

Cc: Komzpa added
Keywords: cursor image width height linux x11 added

comment:7 Changed 11 months ago by Don-vip

Summary: Problem launching josm in Ubuntu TrustyIllegalArgumentException when loading SelectAction cursor

comment:8 Changed 5 months ago by Don-vip

Ticket #14497 has been marked as a duplicate of this ticket.

comment:9 Changed 4 months ago by Don-vip

Ticket #14544 has been marked as a duplicate of this ticket.

comment:10 Changed 4 months ago by Don-vip

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #9209.
Wow I forgot I already found out the root cause... 3 years ago. And this is still not fixed:
https://bugs.launchpad.net/mir/+bug/1286359
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1232471

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.