Modify

Opened 21 months ago

Closed 11 days ago

#12385 closed defect (duplicate)

wrong validator warning for multipolygon relations whose outer members have area tags

Reported by: dieterdreist Owned by:
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: template_report, multipolygon relation, area tags, outer Cc:

Description

What steps will reproduce the problem?

  1. create a MP with an outer member which has area relevant tags
  2. run validator

What is the expected result?

nothing should happen

What happens instead?

you get a misleading warning

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-16 03:00:56 +0100 (Sat, 16 Jan 2016)
Build-Date:2016-01-16 02:34:12
Revision:9480
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9480 en) Mac OS X 10.11.2
Memory Usage: 518 MB / 1820 MB (179 MB allocated, but free)
Java version: 1.8.0_66-b17, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
- TombPlugin (46)
- alignways (31895)
- apache-commons (31895)
- apache-http (31895)
- buildings_tools (31895)
- geochat (31895)
- imagery_offset_db (31895)
- print (31895)
- proj4j (31830)
- reltoolbox (31895)
- reverter (31926)
- undelete (31895)
- utilsplugin2 (31895)

Last errors/warnings:
- W: java.net.SocketException: Socket closed
- E: java.net.SocketException: Socket closed

Attachments (1)

12385.osm (5.8 KB) - added by Don-vip 12 days ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 21 months ago by stoecker

Owner: changed from team to dieterdreist
Status: newneedinfo

Please provide an example and specify the warning you get.

comment:2 Changed 21 months ago by dieterdreist

Owner: dieterdreist deleted
Status: needinfonew

The wording of the warning is:
"Area style on outer way"

An example is this:
https://www.openstreetmap.org/way/23551946
https://www.openstreetmap.org/relation/5867918

I could of course work around this issue by using 2 relations, one for the building and one for the museum, but the way/relation combination is just as correct.

comment:3 Changed 21 months ago by Don-vip

Priority: majornormal

The warning seems correct to me. Plus, what's the point to define a multipolygon with a single outer member? The relation should be simply deleted.

comment:4 Changed 21 months ago by dieterdreist

Don-vip, what do you propose to use instead? The purpose is to avoid overlapping ways.

comment:5 Changed 21 months ago by Don-vip

maybe we could disable the warning if both relation and outer way are named differently. Sorry replied too fast.

comment:6 Changed 21 months ago by dieterdreist

Yes, this goes into the right direction, but there could be objects without a name which still would make sense to be split over several objects, basically it could be any tag. See the tags "start_date", tourism, wikipedia and wikidata, they all are different on these 2 objects, but even in less prominent cases (where e.g. there is just one object with a wikipedia article) you still wouldn't want to associate the wikipedia article to an object to which it doesn't belong. I can also imagine different operators which operate distinct objects / functions on the same space. If you think about layers and/or building levels, use of the multipolygon relation still makes sense as long as the outline is the same.

comment:7 Changed 21 months ago by stoecker

I'd simply say that it's impossible to detect such cases reliable. When such constructs are used the warnings will be there until we get rid of old style entries in the database, as then we can drop the warning completely.

Changed 12 days ago by Don-vip

Attachment: 12385.osm added

comment:8 Changed 12 days ago by Don-vip

Ticket #14624 has been marked as a duplicate of this ticket.

comment:9 Changed 11 days ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15360.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.