Modify

Opened 22 months ago

Closed 22 months ago

Last modified 17 months ago

#11926 closed defect (fixed)

Presets: option to disable alphabetic sorting for a single key (preset attribute)

Reported by: osm.mapper999@… Owned by: team
Priority: normal Milestone: 15.10
Component: Internal preset Version:
Keywords: regression Cc: simon04

Description

I think it would still be nice to have a possibility to have a non-alphabetical sorting. For example when tagging railway signal states the reasonable order for a German Vr signal would be railway:signal:states=vr0;vr1;vr2;off;?. Now you have to come up with some creative names for the label, so that they are shown and applied in the correct order.
(see also ​https://github.com/rurseekatze/OpenRailwayMap/pull/357)

Relates to #5509.

Attachments (0)

Change History (8)

comment:1 Changed 22 months ago by Klumbumbus

Keywords: regression added
Summary: Presets: non-alphabetic sortign for railway signal statesPresets: option to disable alphabetic sorting
Type: enhancementdefect

This is also relevant for the values of the key smoothness, which should be in a defined order instead of alphabetical.

comment:2 Changed 22 months ago by Klumbumbus

Cc: simon04 added

comment:3 Changed 22 months ago by Klumbumbus

Summary: Presets: option to disable alphabetic sortingPresets: option to disable alphabetic sorting for a single key (preset attribute)

comment:4 Changed 22 months ago by simon04

Resolution: fixed
Status: newclosed

In 8877/josm:

fix #11926 - Presets: option to disable alphabetic sorting for a single key

Specify the values_sort="false" attribute for the <combo> of
<multiselect>.

comment:5 Changed 22 months ago by simon04

Milestone: 15.10

comment:6 Changed 22 months ago by Klumbumbus

In 8879/josm:

see #11926 - disable alphabetic sorting also for trail_visibility

comment:8 Changed 17 months ago by Don-vip

Ticket #11921 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.