Modify

Opened 2 years ago

Closed 12 months ago

#11923 closed defect (fixed)

After completing alignment the ways remain highlighted

Reported by: luiswoo Owned by: team
Priority: normal Milestone:
Component: Plugin alignways Version: latest
Keywords: template_report Cc: luiswoo

Description

What steps will reproduce the problem?

fedora 22 Workstation, Java: 1.8.0_60, NVIDIA Driver Version: 352.41

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

https://img-fotki.yandex.ru/get/6841/79462165.2/0_b3ab5_97939a50_orig.png

Revision: 8800
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: simon04
Last Changed Date: 2015-09-27 22:11:06 +0200 (Sun, 27 Sep 2015)
Build-Date: 2015-09-28 01:32:03
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8800

Identification: JOSM/1.5 (8800 ru) Linux Fedora release 22 (Twenty Two)
Memory Usage: 107 MB / 875 MB (46 MB allocated, but free)
Java version: 1.8.0_60, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dicedtea-web.bin.name=javaws.itweb, -Dicedtea-web.bin.location=/usr/bin/javaws.itweb]

Plugins:
- CommandLine (31241)
- FastDraw (31265)
- HouseNumberTaggingTool (31241)
- OpeningHoursEditor (31241)
- PicLayer (31241)
- alignways (31241)
- buildings_tools (31558)
- contourmerge (1013)
- ext_tools (31241)
- gridlayer (${version.entry.commit.revision})
- imagery_offset_db (31241)
- log4j (31231)
- rasterfilters (31509)
- reltoolbox (31241)
- reverter (31241)
- tageditor (31576)
- utilsplugin2 (31463)
- waydownloader (31241)

Last errors/warnings:
- E: Не удалось найти изображение «josm_small.png»
- W: Mappaint style "standard" (Стандартный JOSM (XML; старая версия)) icon "josm_small.png" not found.

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by Don-vip

Status: newneedinfo

what's wrong?

comment:2 Changed 2 years ago by mtraveller

Even if I am not the creator of this ticket, I will try to explain what's wrong (judging by the screenshot, I am also having the same issue) :

Unfortunately, there seems to be an issue with the most recent versions of JOSM: After an alignment has been completed, and even if you deselect the aligned ways, they still remain highlighted on either yellow or green colour. And this is very confusing, especially when you have to do lots of alignments in a certain area. There's no way to "unmark" them, at all.

I am having this issue with every single version of JOSM AFTER 8491 - I've even tried alpha releases.

Let me know if you require more information.

comment:3 Changed 2 years ago by luiswoo

what's wrong?

Могу только добавить видео: https://yadi.sk/i/z9rafgudotGee
Хотя, что не так, довольно очевидно.

GT: I can only add video: https://yadi.sk/i/z9rafgudotGee
Although that is not so, quite obviously.

comment:4 in reply to:  3 Changed 2 years ago by luiswoo

Replying to luiswoo:

what's wrong?

Могу только добавить видео: https://yadi.sk/i/z9rafgudotGee
Хотя, что не так, довольно очевидно.

GT: I can only add video: https://yadi.sk/i/z9rafgudotGee
Although that is not so, quite obviously.

У Яндекса видео сильно лагает, переложил в Dropbox: https://dl.dropboxusercontent.com/u/72970762/JOSM-AlingWays.mp4

GT: We strongly Yandex video lag, shift into Dropbox: https://dl.dropboxusercontent.com/u/72970762/JOSM-AlingWays.mp4

comment:5 Changed 16 months ago by simon04

Owner: changed from luiswoo to team
Status: needinfonew
Summary: ru: Не сбрасывается подсветка сегментов, даже при переходе на другие режимы редактирования (A, S..). Проблема появилась начиная с версии 8558.After completing alignment the ways remain highlighted

comment:6 Changed 12 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o33133:33134] (see #14315).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.