Modify

Opened 2 years ago

Closed 10 days ago

#11315 closed defect (fixed)

Not fully implemented multipolygon support

Reported by: skyper Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin imagery-xml-bounds Version:
Keywords: template_report unclosed way shape Cc:

Description

What steps will reproduce the problem?

  1. download maps
  2. split any closed outer way
  3. look at <shape> entries of modified relation using relation list content menu entry

What is the expected result?

Proper <shape> entries including all nodes of member ways

What happens instead?

Only nodes of closed ways are included

Please provide any additional information below. Attach a screenshot if possible.

Tried to use one way as boundary for three different multipolygons but failed. Have to use three overlapping ways for now.

If intended please document.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-07 08:40:02
Last Changed Author: stoecker
Revision: 8175
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-07 10:18:15 +0200 (Tue, 07 Apr 2015)
Last Changed Rev: 8175

Identification: JOSM/1.5 (8175 en) Linux Debian GNU/Linux 7.8 (wheezy)
Memory Usage: 250 MB / 882 MB (65 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u75-2.5.4-1~deb7u1
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30962)
- conflation (0.1.7)
- download_along (30892)
- imagery-xml-bounds (31019)
- imagery_offset_db (31056)
- jts (31002)
- mirrored_download (30962)
- photoadjust (30964)
- reverter (30990)
- tag2link (31066)
- terracer (30892)
- todo (29154)
- undelete (30892)
- utilsplugin2 (31072)
- waydownloader (30892)
- wikipedia (31035)

Attachments (0)

Change History (1)

comment:1 Changed 10 days ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o33496:33497].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.