Modify

Opened 3 years ago

Closed 20 months ago

Last modified 3 weeks ago

#11270 closed enhancement (fixed)

Test for missing/wrong railway=crossing|level_crossing

Reported by: naoliv Owned by: team
Priority: normal Milestone: 16.02
Component: Core validator Version:
Keywords: Cc: lists@…

Description (last modified by naoliv)

We exchange this for 3 beers if accepted or for 1 beer if something needs to be adjusted (1 beer too if not accepted):

way[railway =~ /^(light_rail|miniature|narrow_gauge|preserved|rail|tram)$/] > node { set .is_in_railway }
way[highway =~ /^(bridleway|cycleway|footway|path|steps)$/] > node[railway != crossing].is_in_railway {
        throwWarning: tr("should have railway=crossing where pedestrians cross");
        fixAdd: "railway=crossing";
}

way[highway =~ /^(bus_guideway|living_street|motorway|pedestrian|primary|raceway|residential|road|secondary|service|tertiary|track|trunk|unclassified)/] > node[railway != level_crossing].is_in_railway {
        throwWarning: tr("should have railway=level_crossing where road cross");
        fixAdd: "railway=level_crossing";
}

Attachments (1)

ticket11270.osm (7.4 KB) - added by Klumbumbus 3 weeks ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 3 years ago by Aun Johnsen <lists@…>

Cc: lists@… added

comment:2 Changed 3 years ago by naoliv

It seems that the beers scared people here

comment:3 Changed 2 years ago by Klumbumbus

Ticket #9300 has been marked as a duplicate of this ticket.

comment:4 Changed 2 years ago by naoliv

Description: modified (diff)

comment:5 Changed 20 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 9839/josm:

fix #11270 - add validator warning for missing/wrong railway=crossing|level_crossing (modified patch by naoliv)

comment:6 Changed 20 months ago by Klumbumbus

Ticket #12519 has been marked as a duplicate of this ticket.

comment:7 Changed 20 months ago by Klumbumbus

Milestone: 16.02

comment:8 Changed 19 months ago by Klumbumbus

Ticket #9298 has been marked as a duplicate of this ticket.

comment:9 Changed 2 months ago by Klumbumbus

In 12595/josm:

see #11270 - don't warn about missing railway=crossing|level_crossing for questionable cases e.g. when the highway changes from residential to footway at the railway crossing node. This avoids an infinite loop of the validator fix button.

comment:10 Changed 2 months ago by Klumbumbus

comment:11 Changed 3 weeks ago by Klumbumbus

In 12895/josm:

see #11270, see #9297 - avoid false positive missing railway crossing warnig for combined railway highway ways.

Changed 3 weeks ago by Klumbumbus

Attachment: ticket11270.osm added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.