Modify

Opened 3 years ago

Closed 6 months ago

#11111 closed defect (fixed)

OSX: Two instances of the preferences dialog if using shortcut ⌘+

Reported by: ar2988-os@… Owned by: team
Priority: normal Milestone: 17.06
Component: Core Version:
Keywords: template_report macosx system shortcut Cc:

Description

What steps will reproduce the problem?

  1. Choose Preferences
  2. Use OK or Cancel to dismiss the preferences dialog
  3. You will now see a second instance of the preferences dialog

Please provide any additional information below. Attach a screenshot if possible.

This is a long-standing bug - a regression which occurred more than two years ago.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-02-01 02:33:54
Last Changed Author: Don-vip
Revision: 7995
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-01-31 15:17:59 +0100 (Sat, 31 Jan 2015)
Last Changed Rev: 7995

Identification: JOSM/1.5 (7995 en) Mac OS X 10.9.5
Memory Usage: 767 MB / 3641 MB (185 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- ImportImagePlugin (30892)
- InfoMode (30892)
- PicLayer (30892)
- cadastre-fr (30892)
- download_along (30892)
- editgpx (30892)
- geotools (30892)
- imagery_offset_db (30892)
- jts (30892)
- log4j (30892)
- measurement (30892)
- opendata (30911)
- poly (30892)
- reverter (30892)
- turnrestrictions (30892)
- undelete (30892)
- utilsplugin2 (30892)
- waydownloader (30892)

Last errors/warnings:
- W: TMS - Failed downloading http://ecn.t2.tiles.virtualearth.net/tiles/a120222122311121300.jpeg?g=3262: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t2.tiles.virtualearth.net/tiles/a120222122311121230.jpeg?g=3262: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t1.tiles.virtualearth.net/tiles/a120222122311121212.jpeg?g=3262: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t1.tiles.virtualearth.net/tiles/a120222122311121322.jpeg?g=3262: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t3.tiles.virtualearth.net/tiles/a120222122311121232.jpeg?g=3262: Attribution is not loaded yet

Attachments (3)

Bildschirmfoto 2015-03-17 um 14.19.42.png (188.5 KB) - added by Lesath 3 years ago.
Multiple instances of "Prefernces" in JOSM
josm_pref_shortcut.gif (936.8 KB) - added by andygol 22 months ago.
Two instance of Preferences dialog
JOSM Preferences 2017-06-06 01-12-52.png (158.3 KB) - added by andygol 6 months ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 3 years ago by Don-vip

Keywords: macosx added
Summary: Two instances of the preferences dialogOSX: Two instances of the preferences dialog

Changed 3 years ago by Lesath

Multiple instances of "Prefernces" in JOSM

comment:2 Changed 3 years ago by Lesath

If you just try to open multiple instances it looks like the attached picture.

comment:3 Changed 3 years ago by ar2988-os@…

On further testing, you get one instance of the preferences dialog if you open it from the JOSM menu or from the button on the toolbar. You get two instances if you type the keyboard shortcut (command-,) once.

Changed 22 months ago by andygol

Attachment: josm_pref_shortcut.gif added

Two instance of Preferences dialog

comment:4 Changed 22 months ago by andygol

I confirm the same issue on all Macs which I tried. Shortcut ⌘+, cause two instance of Preferences dialog

Two instance of Preferences dialog

comment:5 Changed 6 months ago by Don-vip

Keywords: system shortcut added
Summary: OSX: Two instances of the preferences dialogOSX: Two instances of the preferences dialog if using shortcut ⌘+

comment:6 Changed 6 months ago by Don-vip

I can't reproduce it on my VM, does this bug still occur with latest JOSM?

Changed 6 months ago by andygol

comment:7 Changed 6 months ago by andygol

Yes! It still exists!

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 16:19:58 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-29 14:25:03
Revision:12275
Relative:URL: /trunk

Identification: JOSM/1.5 (12275 en) Mac OS X 10.12.5
OS Build number: Mac OS X 10.12.5 (16F73)


Last edited 6 months ago by andygol (previous) (diff)

comment:8 Changed 6 months ago by Don-vip

OK I found a way to reproduce :)

comment:9 Changed 6 months ago by Don-vip

Milestone: 17.06

comment:10 Changed 6 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12320/josm:

fix #11111 - don't register automatic shortcuts

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.