Modify

Opened 3 years ago

Closed 2 months ago

#10838 closed defect (fixed)

on incomplete relation: "combine way" deletes all ways

Reported by: malenki Owned by: team
Priority: major Milestone: 17.07
Component: Core Version:
Keywords: relation, incomplete, combine way Cc:

Description

How to reproduce:

  • get a relation with at least three connected ways (no difference if these are connected inner or outer ways of a multipolygon or a route. For testing purposes a route would be the easier choice)
  • download two of these ways belonging to the relation
  • right click the route relation in the relation window and "Select members"
  • apply the Tool —> "Combine Way"

Result: all selected ways disappear, their nodes remain (JOSM reports the ways as deleted)

expected result: A warning that not all selected ways can be combined since they are not downloaded

Sure, it is a stupid thing trying to combine not-downloaded ways but since this happened to me today by chance I'd assume I am not the only one to whom this error may happen.
I tested back to r6210 for this behaviour which showed there, too.

Maybe this issue is related to #8082?

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by skyper

Right, JOSM should mot combine/merge incomplete objects.

comment:2 Changed 2 years ago by akks

When we select incomplete ways there are also exceptions in L and Q, Utilsplugin actions etc.
There are 2 options:

1) Not select incomplete ways (bad solution? they are explicitly found by Search dialog with appropriate checkbox)
2) Add checks into all correspoding actions (C, L, Q, etc.)

Version 0, edited 2 years ago by akks (next)

comment:3 Changed 2 months ago by Don-vip

Milestone: 17.07

comment:4 Changed 2 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12527/josm:

fix #10838 - add robustness if incomplete ways are selected

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.