Modify

Opened 3 years ago

Closed 3 weeks ago

#10780 closed defect (fixed)

Undeleted relation not displayed in "Relations" window

Reported by: naoliv Owned by: team
Priority: normal Milestone: 17.07
Component: Core Version:
Keywords: undelete relation Cc:

Description

Restore any deleted relation using the undelete plugin (r1691868, for example) and then note how there isn't anything in the Relations window.
The relation is present, however, since selecting everything with Ctrl+A we can see it.

JOSM:

epository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-11-24 02:33:57
Last Changed Author: Don-vip
Revision: 7743
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-11-23 23:54:40 +0100 (Sun, 23 Nov 2014)
Last Changed Rev: 7743

Identification: JOSM/1.5 (7743 en) Linux Debian GNU/Linux testing (jessie)
Memory Usage: 247 MB / 8158 MB (113 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u71-2.5.3-2
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- Create_grid_of_ways (30762)
- ImageryCache (30738)
- OpeningHoursEditor (30737)
- PicLayer (30762)
- SimplifyArea (30791)
- buildings_tools (30762)
- conflation (0.1.7)
- contourmerge (1012)
- download_along (30762)
- editgpx (30737)
- geotools (30762)
- importvec (30762)
- jts (30762)
- log4j (30762)
- measurement (30737)
- merge-overlap (30784)
- notes (v0.9.5)
- opendata (30806)
- pbf (30762)
- pdfimport (30737)
- poly (30738)
- reverter (30737)
- scripting (30702)
- todo (29154)
- turnrestrictions (30762)
- undelete (30762)
- utilsplugin2 (30762)

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by Don-vip

Component: CorePlugin undelete

comment:2 Changed 20 months ago by simon04

The results of some debugging: The relation list shows only visible relations. After undeleting, the objects are invisible (see [o29555], #7116).

comment:3 Changed 3 weeks ago by Don-vip

Component: Plugin undeleteCore
Keywords: undelete relation added
Milestone: 17.07

comment:4 Changed 3 weeks ago by Don-vip

Ticket #10985 has been marked as a duplicate of this ticket.

comment:5 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 12528/josm:

fix #10780 - display undeleted relations in relation list

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.