Modify

Opened 3 years ago

Closed 2 years ago

Last modified 18 months ago

#10684 closed defect (fixed)

Fix icon scaling

Reported by: stoecker Owned by: team
Priority: normal Milestone: 16.01
Component: Core Version:
Keywords: icon scale Cc: Klumbumbus, skyper

Description

Currently we do hard scaling of many icons to 24 or 16 pixel (preferences tabs?).

This should be a settings value, so that a user can choose "big icons" for large screen resolutions.

Attachments (2)

squareicons.png (62.4 KB) - added by Klumbumbus 3 years ago.
upscaling.png (15.1 KB) - added by Klumbumbus 2 years ago.

Download all attachments as: .zip

Change History (53)

comment:1 Changed 3 years ago by Don-vip

If you think to people with Retina screens that won't change anything. The OSX Aqua look and feel force the icon size and we can't do anything about it except switching from icon tabs to text tabs.

comment:2 Changed 3 years ago by stoecker

Where does it force the icon size?

  • toolbar
  • menu
  • mapview
  • preferences
  • table entries
  • ...

We have many places were we use scaled images. And not all of them are proper anymore with 4k displays.

Thought I will start major rework only if I have a 4k screen :-)

comment:3 Changed 3 years ago by Don-vip

at least preference tabs for sure:

One other thing to keep in mind about JTabbedPane objects in OS X is that they have a standard size. If you put an image in a tab, the image is scaled to fit the tab instead of the tab to the image. This standard size applies to several other Swing components as well.

I don't know what "other Swing components" are also impacted.

comment:4 Changed 3 years ago by Klumbumbus

Cc: Klumbumbus added

comment:5 Changed 3 years ago by stoecker

See also #10688 comments.

comment:6 Changed 3 years ago by stoecker

In 7687/josm:

see #10684, see #10688 fix icon scaling a bit

comment:7 Changed 3 years ago by stoecker

In 7691/josm:

see #10684 - large icons also for imagery

comment:8 Changed 3 years ago by stoecker

In 7693/josm:

see #10684 - no double loading of images, cleanup action icons - menu icon size defaults now to 16x16 (previously most time 24x24) with some errors - maybe 24x24 should be default?

Changed 3 years ago by Klumbumbus

Attachment: squareicons.png added

comment:9 Changed 3 years ago by Klumbumbus

icons are stretched now to square size. See for example shop=beauty ("Schönheitssalon" in the screenshot)


Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-11-02 17:58:46
Last Changed Author: Don-vip
Revision: 7695
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-11-02 18:43:27 +0100 (Sun, 02 Nov 2014)
Last Changed Rev: 7695

Identification: JOSM/1.5 (7695 de) Windows 7 32-Bit
Memory Usage: 326 MB / 742 MB (101 MB allocated, but free)
Java version: 1.7.0_71, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:C:\Program Files\Java\jre7\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Program Files\josm-latest.jnlp, -Djnlpx.remove=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=256m,768m, -Djnlpx.splashport=54219, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAA==]
Dataset consistency test: No problems found

comment:10 Changed 3 years ago by Klumbumbus

BTW why is milestone 14.12 and not 14.11?

comment:11 Changed 3 years ago by stoecker

In 7696/josm:

Fix scaling, see #10684

comment:12 Changed 3 years ago by stoecker

One place used setMaxSize(), the other used setSize(). Seems my choice was the wrong one. Fixed.

BTW why is milestone 14.12 and not 14.11?

Because it wont be finished in 14.11 :-)

comment:13 in reply to:  12 ; Changed 3 years ago by Don-vip

Replying to stoecker:

Because it wont be finished in 14.11 :-)

is there so much work? We still have 4 entire weeks, it's the longest development period of this year as I pushed October release sooner :)

comment:14 in reply to:  13 ; Changed 3 years ago by stoecker

Replying to Don-vip:

is there so much work? We still have 4 entire weeks, it's the longest development period of this year as I pushed October release sooner :)

  • Fix overlay handling (see comment in one of the last checkins)
  • Find and replace all hardcoded resizings
  • At least ImageSizes.LIST type for layer and other lists is missing as 16x16, probably more types
  • Add ImageProvider passthrough for styles and probably other places (or maybe ImageResource - I'm not sure yet if my new function for JosmAction should use ImageResource instead).
  • test and check plugins for incompatibilities.

And all this together with the fact that I have probably no more time as of tomorrow. If this was my work then probably 2 days only. :-)

comment:15 in reply to:  14 Changed 3 years ago by Don-vip

Replying to stoecker:

  • test and check plugins for incompatibilities.

I have updated some of them in [o30806:30811].

comment:16 Changed 3 years ago by Don-vip

In 7731/josm:

see #10684 - fix javadoc

comment:17 Changed 3 years ago by Don-vip

In 7746/josm:

see #10684 - fix deprecation warning

comment:18 Changed 3 years ago by Don-vip

Milestone: 14.1215.01

comment:19 Changed 3 years ago by Don-vip

Milestone: 15.0115.02

move tickets that have not been treated this month to next milestone

comment:20 Changed 3 years ago by stoecker

In 8095/josm:

see #10684 - add proper overlay interface for ImageProvider()

comment:21 Changed 3 years ago by stoecker

In 8097/josm:

see #10684, see #10688 - fix image scaling for mappaint

comment:22 Changed 3 years ago by stoecker

Ticket #10688 has been marked as a duplicate of this ticket.

comment:23 Changed 3 years ago by skyper

Cc: skyper added
Keywords: icon scale added

comment:24 Changed 3 years ago by stoecker

Milestone: 15.0215.03

Still a lot to do.

comment:25 Changed 3 years ago by stoecker

Milestone: 15.0315.04

Move one month.

comment:26 Changed 3 years ago by stoecker

Milestone: 15.0415.05

comment:27 Changed 3 years ago by stoecker

In 8323/josm:

see #10684 - remove remaining overlay() calls

comment:28 Changed 3 years ago by Don-vip

Milestone: 15.0515.06

comment:29 Changed 3 years ago by Don-vip

Milestone: 15.0615.07

skip milestone 15.06

comment:30 Changed 2 years ago by Don-vip

Milestone: 15.0715.08

Milestone renamed

comment:31 Changed 2 years ago by Don-vip

Milestone: 15.08

comment:32 Changed 2 years ago by stoecker

In 9251/josm:

see #10684 - extend SVG with small dimension when a larger image is requested

comment:33 Changed 2 years ago by Don-vip

Can you please enable Checkstyle in your IDE? Since r9235 it should work without any particular configuration.

comment:34 Changed 2 years ago by stoecker

I think in principle this ticket is done. Remaining task would be to search the core and plugin code and fix all places, where hardcoded image sizes are used.

Can you please enable Checkstyle in your IDE? Since r9235 it should work without any particular configuration.

That's impossible. I use no IDE :-)

comment:35 in reply to:  34 ; Changed 2 years ago by Don-vip

Replying to stoecker:

That's impossible. I use no IDE :-)

not an excuse ;)

comment:36 Changed 2 years ago by Don-vip

Milestone: 16.01

comment:37 in reply to:  35 Changed 2 years ago by stoecker

Milestone: 16.01

Replying to Don-vip:

Replying to stoecker:

That's impossible. I use no IDE :-)

not an excuse ;)

Baah. Vi. That's only the last resort when nothing else is available. That's my nerd check: Someone who can use vi is a nerd. Sadly I fall in that group.

comment:38 Changed 2 years ago by Don-vip

In 9252/josm:

see #10684 - update to checkstyle 6.14.1

comment:39 Changed 2 years ago by Don-vip

Resolution: fixed
Status: newclosed

comment:40 Changed 2 years ago by stoecker

In 9253/josm:

see #10684 - use squared toolbar buttons always, move side button image size definition to ImageProvider

comment:41 Changed 2 years ago by Klumbumbus

In 9275/josm:

see #10684 - use svg logo for scaling in toolbar (since r9251)

comment:42 Changed 2 years ago by Klumbumbus

was the milestone accidentally removed in comment:37?

Last edited 2 years ago by Klumbumbus (previous) (diff)

comment:43 in reply to:  32 ; Changed 2 years ago by Klumbumbus

Replying to stoecker:

In 9251/josm:

see #10684 - extend SVG with small dimension when a larger image is requested

While some icons do upscale in the toolbar, some don't. See screenshot


Food preset icon, Show ID mappaint style icon and Layer Checker mappaint style icon. (The other small icons are png)

Last edited 2 years ago by Klumbumbus (previous) (diff)

Changed 2 years ago by Klumbumbus

Attachment: upscaling.png added

comment:44 in reply to:  42 Changed 2 years ago by stoecker

Milestone: 16.01

Replying to Klumbumbus:

was the milestone accidentally removed in comment:37?

Yes. Parallel editing...

comment:45 in reply to:  43 Changed 2 years ago by stoecker

Replying to Klumbumbus:

Food preset icon, Show ID mappaint style icon and Layer Checker mappaint style icon. (The other small icons are png)

Are the small SVG toolbar entries all styles?

comment:46 Changed 2 years ago by Klumbumbus

The food Icon is from internal preset

comment:47 Changed 2 years ago by stoecker

Resolution: fixed
Status: closedreopened

Works with the uncleaned SVN icons, but not with cleaned ones in the jar. Strange.

comment:48 Changed 2 years ago by Don-vip

Maybe related: see problems encountered in #12201 and how [o31865] fixed them.

comment:49 Changed 2 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

In 9281/josm:

fix #10684 - fix SVG upscaling

comment:50 Changed 18 months ago by stoecker

In 10356/josm:

see #9995, see #10684 - remove more hardcoded places of images

comment:51 Changed 18 months ago by stoecker

In 10357/josm:

see #9995, see #10684 - remove more hardcoded places of images

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.