Modify

Opened 3 years ago

Closed 4 weeks ago

Last modified 3 weeks ago

#10542 closed defect (fixed)

highlight of validator layer broken

Reported by: Klumbumbus Owned by: team
Priority: normal Milestone: 17.11
Component: Core validator Version:
Keywords: template_report Cc: skyper

Description

What steps will reproduce the problem?

  1. validate the attached file "errors.osm"
  2. in the validator dialog expand the warning group. there are three folders in there.
  3. by clicking on the different folders the corresponding erros in the map view of the validator layer change from yellow casing to fully yellow filled.

What are the problems?

  1. sometimes by clicking another warning folder the fully yellow filled highlight does not change. it remains on the previous selected errors. Sometimes it gets updated when you move the mouse on the map view. sometimes it gets updated when you move the mouse on top of an object with an error in the map view.
  1. There is no way to go back to the casing for all errors. Atleast one error always stays with the fully filled highlight. By clicking on the free space in the validator dialog it should unselect all errors and therefore change the fully filled display to the casing version. This is important because the fully filled highlight hides the data and it is hard to edit such an object. I often hide the whole validator layer when fixing data because the fully filled error highlight bothers me.
  1. I hope you understand what I try to explain :)
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-21 01:34:10
Last Changed Author: stoecker
Revision: 7573
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-20 21:37:54 +0200 (Sat, 20 Sep 2014)
Last Changed Rev: 7573

Identification: JOSM/1.5 (7573 en) Windows 7 32-Bit
Memory Usage: 247 MB / 742 MB (161 MB allocated, but free)
Java version: 1.7.0_67, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.policy=file:C:\Program Files\Java\jre7\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Program Files\josm-latest.jnlp, -Djnlpx.remove=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=256m,768m, -Djnlpx.splashport=51600, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAA==]
Program arguments: [--debug]
Dataset consistency test: No problems found

Plugins:
- DirectUpload (30416)
- HouseNumberTaggingTool (30416)
- OpeningHoursEditor (30609)
- PicLayer (30436)
- Tracer2 (30416)
- buildings_tools (30485)
- download_along (30416)
- editgpx (30634)
- imagery_offset_db (30534)
- measurement (30641)
- notes (v0.9.4)
- public_transport (30416)
- reltoolbox (30587)
- reverter (30521)
- terracer (30643)
- turnrestrictions (30651)
- undelete (30416)
- utilsplugin2 (30460)

Last errors/warnings:
- W: Detected deprecated 'canvas{background-color}' in 'https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip' which will be removed shortly. Use 'fill-color' instead.
- E: Failed to locate image 'http://josm.openstreetmap.de/attachment/wiki/Styles/sac_scale/sac_scale_icon.png'
- W: java.lang.IllegalArgumentException: component not found in tabbed pane
- E: Failed to locate image 'http://josm.openstreetmap.de/attachment/wiki/Styles/sac_scale/sac_scale_icon.png'
- W: Mappaint style "standard" (maxspeed2.0) icon "http://josm.openstreetmap.de/attachment/wiki/Styles/sac_scale/sac_scale_icon.png" not found.

Attachments (2)

errors.osm (2.9 KB) - added by Klumbumbus 3 years ago.
04.gif (34.7 KB) - added by Klumbumbus 2 months ago.

Download all attachments as: .zip

Change History (16)

Changed 3 years ago by Klumbumbus

Attachment: errors.osm added

comment:1 Changed 3 years ago by skyper

Cc: skyper added

comment:2 Changed 3 years ago by Don-vip

Milestone: 14.09

comment:3 Changed 3 years ago by Don-vip

Milestone: 14.0914.10

comment:4 Changed 3 years ago by Don-vip

Milestone: 14.1014.11

minor bug and not enough time this week, delay to next milestone.

comment:5 Changed 3 years ago by Don-vip

Milestone: 14.1114.12

comment:6 Changed 3 years ago by Don-vip

Milestone: 14.1215.01

comment:7 Changed 3 years ago by Klumbumbus

related to #10968

comment:8 Changed 3 years ago by Don-vip

Milestone: 15.0115.02

comment:9 Changed 3 years ago by Don-vip

Milestone: 15.02

comment:10 in reply to:  description ; Changed 15 months ago by Klumbumbus

Replying to Klumbumbus:

  1. sometimes by clicking another warning folder the fully yellow filled highlight does not change. it remains on the previous selected errors. Sometimes it gets updated when you move the mouse on the map view. sometimes it gets updated when you move the mouse on top of an object with an error in the map view.

It seems this was fixed meanwhile. The only minor problem is that the casing of the validator layer has sharp step like rendering (no antialiasing?; will maybe fixed by #12415?). When you move the mouse over the way, the casing becomes smooth and straight. (I don't know if this is intended for performance reasons.)

  1. There is no way to go back to the casing for all errors. Atleast one error always stays with the fully filled highlight. By clicking on the free space in the validator dialog it should unselect all errors and therefore change the fully filled display to the casing version.

This is still true.

the fully filled highlight hides the data and it is hard to edit such an object.

This was mainly fixed by #10968

Last edited 15 months ago by Klumbumbus (previous) (diff)

Changed 2 months ago by Klumbumbus

Attachment: 04.gif added

comment:11 in reply to:  10 Changed 2 months ago by Klumbumbus

Replying to Klumbumbus:

Replying to Klumbumbus:

  1. sometimes by clicking another warning folder the fully yellow filled highlight does not change. it remains on the previous selected errors. Sometimes it gets updated when you move the mouse on the map view. sometimes it gets updated when you move the mouse on top of an object with an error in the map view.

It seems this was fixed meanwhile. The only minor problem is that the casing of the validator layer has sharp step like rendering (no antialiasing?; will maybe fixed by #12415?). When you move the mouse over the way, the casing becomes smooth and straight. (I don't know if this is intended for performance reasons.)

This is back at the old state for me:

comment:12 Changed 4 weeks ago by Don-vip

Milestone: 17.11

comment:13 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 13149/josm:

fix #10542 - fix broken layer invalidation when selection changes in validator dialog

comment:14 Changed 3 weeks ago by Klumbumbus

Works fine for me. (Only problem left is the missing antialiasing, see comment:10, but this is a very minor problem and much likely covered by #12415.)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.